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Bursting (Intelligence and Premium)

NOTE: Multiple SAP Concur product versions and UI themes are available, so this content might contain images or procedures that do not precisely match your implementation. For example, when SAP Fiori UI themes are implemented, home page navigation is consolidated under the SAP Concur Home menu.
Section 1:  Overview

Report bursting allows a user to easily distribute the contents of a report to a group of individuals. This varies from a standard distribution list in that every recipient receives only the information from that report appropriate to their station. For example, if a custom report called Expense Reports By BI Manager report was ‘bursted out’ to all BI Managers in a company, each BI Manager would receive only report information relevant to the people reporting up to them.

Bursting can be based on: 

· Reporting Hierarchy relationship

· BI Manager relationship

· Custom fields (defined in the Employee Import): This method allows the client to create its own relationships using the Employee Import.
· IMPORTANT: It is best practice to only use report bursting as part of a strategic and very targeted effort for only specific recipients. Report bursting is not intended or recommended for a large number of recipients.

Bursting a report to multiple recipients or a complex report design can result in potential performance impacts. If you are experiencing run failures for a bursting report, consider splitting your report into more manageable sections by considering the date range of your report data set, and further separating the report by groups, organizational structures, and/or recipient names.
In this Guide

In this guide, the Cognos version 10 user interface is called Cognos 10 UI, and the Cognos version 11 user interface is called Cognos 11 UI.
Section 2:  Getting Ready - Custom Fields

For bursting based on the Reporting hierarchy or BI manager relationship, no additional configuration is required – the Reporting database already contains the hierarchy or BI manager information. If you want to create reports for bursting based on the hierarchy or BI manager information, refer to Procedure – Generating the Report on the following pages.

To create a report that is to burst based on custom field, however, requires using the Employee Import. The import creates the relationship in Concur Expense. Then, that information is transferred (archived) to the Reporting database, just like other report-related data. It then becomes available in the model.

Employee Import

In the Employee Import, the 1000 and 1100 record are used for bursting. These fields create the values for the custom bursting table of the transactional database, which is archived to the Reporting database.  
Record Type 1000

These are required fields:

· Emp ID: The Employee ID of the user that will receive the bursted report (JSMITH, for example)

· Bursting ID: A user-defined value that groups users who receive bursted reports (Cost Center owners, for example)

· Bursting Value: The actual value that the report will be bursted off of (if a user wanted to receive all data on Cost Center 1234, for example)

· Future Use Fields: There are ten future-use fields. Currently, any data in these field will be ignored but they must be accounted for with commas

A sample record:

1000,JSMITH,COST_CENTER_OWNERS,1234,,,,,,,,,,

Record Type 1100

These fields are used to delete values from the custom bursting table of the transactional database. The same ten fields as the 1000 Record Type are required.  

To uses these fields:

· If DELETE_ALL_RECORDS is specified in any of the required fields, then all records that match the remaining values will be deleted. For example, the row below would delete all records for employee JSMITH with the Bursting ID of COST_CENTER_OWNERS:

1100,JSMITH,COST_CENTER_OWNERS,DELETE_ALL_RECORDS,,,,,,,,,,
· To quickly delete all records in the custom bursting table, the following record can be used:

1100,DELETE_ALL_RECORDS,DELETE_ALL_RECORDS,DELETE_ALL_RECORDS,,,,,,,,,,
For more information, about the Employee Import chapter of the Expense – Import and Extract Specifications.

Archive Required

Information inserted or deleted will not be immediately available in the Reporting Database. An archive must be successfully completed before this information can be utilized in the model. 

Section 3:  Procedure – Generating the Report

Bursting functionality is built into Cognos, but requires reports to be set up in a specific manner. Follow the steps below if you would like to burst a report.

Step 1: Creating the Report (Cognos 11 UI)

A report that is to be bursted must contain a minimum of two components: 

· Content Query (what data do you wish to see?) 
– and –

· Recipient Query (who is going to receive this report?)

In order for bursting to work properly, the data element you want to burst a report to must be contained in the report. For example, if a report writer wishes to burst a report to all users with a Cognos role in a Reporting Group, then the Reporting Group must be included in the Content Query (chosen from the Expense Subject Header). Correspondingly, the Recipient Query must contain the users within the Reporting Group that will be receiving the report (chosen from the Bursting Subject Header). 

Bursting items are available to select at the following location: Concur Data Warehouse > Expense > Bursting:
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For example:  In a very simple report, the Content Query (Query1 within Report) will contain Approved Amount, Reporting Group, and Total. This report will allow the report writer to view the Approved Amount for each Reporting Group. 
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Prior to bursting, if the report writer wanted to distribute this information to each Reporting Group owner, they would need to create an individual report for each Reporting Group and then run the report (or filter the report for each individual group).
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With bursting, the Recipient Query (Query2 within Report) needs to be created. From the Bursting Subject Header, Reporting Group and Employee Email Address is added.

Step 1: Creating the Report (Cognos 10 UI)
A report that is to be bursted must contain a minimum of two components: 

· Content Query (what data do you wish to see?) 
– and –

· Recipient Query (who is going to receive this report?)

In order for bursting to work properly, the data element you want to burst a report to must be contained in the report. For example, if a report writer wishes to burst a report to all users with a Cognos role in a Reporting Group, then the Reporting Group must be included in the Content Query (chosen from the Expense Subject Header). Correspondingly, the Recipient Query must contain the users within the Reporting Group that will be receiving the report (chosen from the Bursting Subject Header). 

Bursting items are available to select at the following location: Concur Data Warehouse > Expense > Bursting:
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For example:  In a very simple report, the Content Query (Query1 within Report Studio) will contain Approved Amount, Reporting Group, and Total. This report will allow the report writer to view the Approved Amount for each Reporting Group. 
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Prior to bursting, if the report writer wanted to distribute this information to each Reporting Group owner, they would need to create an individual report for each Reporting Group and then run the report (or filter the report for each individual group).
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With bursting, the Recipient Query (Query2 within Report Studio) needs to be created. From the Bursting Subject Header, Reporting Group and Employee Email Address is added.

Step 2: Configuring the Report for Bursting (Cognos 11 UI)

Once the Content and Recipient Queries have been created, the report needs to be configured to be bursted. In Report edit mode, select Report > Burst Options. The dialog box below will be displayed:
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By default, the Make report available for bursting check box is not selected. To burst the report, this check box must be selected (enabled). Enabling this check box makes the Burst Groups and Burst Recipient sections active. All items in this dialog box must be populated in order to successfully burst a report.

Burst Groups
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Under the Burst Groups options, a query must be selected to define the data that is going to be returned. From the list, select the Content Query defined in Step 1 (Query1 in this example).  
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The Label list specifies the label that will used to label each burst report (Reporting Group, in this example).

The last element in the Burst Groups section that needs to be populated is the Groups. The value selected here is the data element that the report burst will be grouped by. In this example, the report burst is going to be grouped by the Reporting Group. To populate this, click the edit icon in the lower left corner. The Grouping & sorting dialog box appears.

NOTE: When defining burst groups, it is best practice to use concept fields instead of custom fields. Concept fields are indexed. Custom fields are not indexed, therefore it is more efficient to use concept fields for report bursting.
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To select a data element to group by, double click the desired data element. Once the desired data element has been selected and is displayed under the Groups header, click OK. 
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At this point, the Burst Groups selection should be completed, and should look similar to this.

Burst Recipients
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With the Burst Groups section completed, the Burst Recipient section must be populated. First, a query must be selected to define who is going to receive this report. From the list, select the Recipient Query defined in Step 1 (Query2 in this example).  
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From the Data Item list, the item that uniquely identifies each recipient needs to be identified. In this example, Employee E-mail Address:
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The Type list defines the option the report writer wishes to use to distribute the report. Although there are three options available (Automatic, Email addresses, and Directory entries) Intelligence ONLY supports the Email addresses option.  

The final step is to define the master detail relationship. This creates the link between the Content Query and Recipient Query using a common data element. Select the ellipse to the right of the field to open the Master detail relationships dialog box.
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Click the New Link button to establish a link between the two queries. 

In this example, the Reporting Group is the common element between the two queries. By default, the new link is associated to the first data element of each query. Selecting the data element will move the link to the data element selected (in this case, Reporting Group).
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Once the relationship has been established, click OK.

At this point, all the required data has been identified for the report, and it is ready for bursting.  

The Burst options dialog box should be similar to this:
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Step 2: Configuring the Report for Bursting (Cognos 10 UI)
Once the Content and Recipient Queries have been created, the report needs to be configured to be bursted. In Report Studio, select File > Burst Options. The dialog box below will be displayed:
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By default, the Make report available for bursting check box is no selected. To burst the report, this check box must be selected (enabled). Enabling this check box makes the Burst Groups and Burst Recipient sections active. All items in this dialog box must be populated in order to successfully burst a report.

Burst Groups
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Under the Burst Groups options, a query must be selected to define the data that is going to be returned. From the list, select the Content Query defined in Step 1 (Query1 in this example).  

The Label list specifies the label that will used to label each burst report (Reporting Group, in this example).
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The last element in the Burst Groups section that needs to be populated is the Groups. The value selected here is the data element that the report burst will be grouped by. In this example, the report burst is going to be grouped by the Reporting Group. To populate this, click the edit icon in the lower left corner. The Grouping & Sorting dialog box appears.

NOTE: When defining burst groups, it is best practice to use concept fields instead of custom fields. Concept fields are indexed. Custom fields are not indexed, therefore it is more efficient to use concept fields for report bursting.
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To select a data element to group by, double click the desired data element. Once the desired data element has been selected and is displayed under the Groups header, click OK. 
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At this point, the Burst Groups selection should be completed, and should look similar to this.

Burst Recipients
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With the Burst Groups section completed, the Burst Recipients section must be populated. First, a query must be selected to define who is going to receive this report. From the list, select the Recipient Query defined in Step 1 (Query2 in this example).  

From the Data Item list, the item that uniquely identifies each recipient needs to be identified. In this example, Employee E-mail Address:

The Type list defines the option the report writer wishes to use to distribute the report. Although there are three options available (Automatic, Email addresses, and Directory entries) Intelligence ONLY supports the Email addresses option.  

The final step is to define the master detail relationship. This creates the link between the Content Query and Recipient Query using a common data element. Select the ellipse to the right of the field to open the Master Details Relationship dialog box.
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Click the New Link button to establish to create a link between the two queries. 

In this example, the Reporting Group is the common element between the two queries. By default, the new link is associated to the first data element of each query. Selecting the data element will move the link to the data element selected (in this case, Reporting Group).
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Once the relationship has been established, click OK.

At this point, all the required data has been identified for the report, and it is ready for bursting.  

The Burst Options dialog box should be similar to this:
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Step 3: Distributing the Report (Cognos 11 UI)

Now that the report has been created and configured for bursting, the distribution of the report needs to be set up. If running the report interactively, click the More icon, [image: image16.png]


, for the report, and then click Run as. 

[image: image17.png]7 Editreport

[ Create report view

[ View versions

% Createanew job
Copy or move

Create shortcut

Properties





In the Run as dialog, ensure the Run in the background and Burst the report settings are enabled. 

· IMPORTANT: If the Burst the report setting is not enabled, the report will not be successfully burst.
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If the report is being scheduled, a similar change needs to be made in the schedule settings. On the Options tab in the scheduling dialog, the Burst the report setting must be enabled. Enabling this setting allows the bursting option to be available for the report.

You can access the Options tab by clicking the More icon for the report, and then clicking Properties > Schedule tab > Create schedule button or Edit link > Options tab. 
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Step 3: Distributing the Report (Cognos 10 UI)
Now that the report has been created and configured for bursting, the distribution of the report needs to be set up. If running the report interactively, click the Run With Options icon. On the Run with Options screen, click the Advanced Options link:
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On the Advanced Options screen, ensure the Run in the Background radio button is selected under the Time and Mode header. Enabling this radio button causes the Burst the report option to be available:
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· IMPORTANT: If the Burst the report check box is not selected, the report will not be successfully burst.

If the report is being scheduled, a similar change needs to be made. On the Schedule screen, the Override the default values check box must be enabled:
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Selecting this check box allows the bursting option to be available for the report:
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